mirror of
https://github.com/dashpay/dash.git
synced 2024-12-25 20:12:57 +01:00
595a1b3a8e
f13e642c831c5689cb2bb7f5c4f9cb4c0c03ef21 build: Disable valgrind when building zeromq package in depends (Hennadii Stepanov)
b970f03beae0f3ae6a796f0e3b97732fc579f6aa build: Disable libbsd when building zeromq package in depends (Hennadii Stepanov)
77899991b1e29a45bc377b21330148cb7cc08923 build: Update netbsd_kevent_void.patch (Hennadii Stepanov)
Pull request description:
Since v4.3.3 (068385c951
) `libzmq` uses `libbsd` by default.
This PR disables `libbsd` explicitly, as it's not a part of our depends. Zeromq will fallback to its internal `strlcpy` implementation.
Otherwise, on systems with installed `libbsd-dev` package the `zeromq` package build system erroneously detects `libbsd` package from the host system:
```diff
--- a/libzmq.pc
+++ b/libzmq.pc
@@ -8,5 +8,5 @@
Version: 4.3.4
Libs: -L${libdir} -lzmq
Libs.private: -lpthread
-Requires.private:
+Requires.private: libbsd
Cflags: -I${includedir}
```
This causes the `configure` fails to detect the `zeromq` package:
```
configure: WARNING: libzmq version 4.x or greater not found, disabling
```
---
Other minor improvements:
- fixed `netbsd_kevent_void.patch` offset
- disabled valgrind as it's used in unit tests which we do not run:
```diff
--- a/zmq-configure-output
+++ b/zmq-configure-output
@@ -119,11 +119,6 @@
checking whether the g++ -m64 linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking dynamic linker characteristics... (cached) GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
-checking for valgrind... valgrind
-checking for Valgrind tool memcheck... memcheck
-checking for Valgrind tool helgrind... helgrind
-checking for Valgrind tool drd... drd
-checking for Valgrind tool exp-sgcheck... exp-sgcheck
checking linker version script flag... --version-script
checking if version scripts can use complex wildcards... yes
checking for working posix_memalign... yes
```
ACKs for top commit:
fanquake:
ACK f13e642c831c5689cb2bb7f5c4f9cb4c0c03ef21
Tree-SHA512: d4c86d4a841eb6e7c32157e84972243072f905496c2a4c14ec6f6ab4216df6695cbf29baa2233ce27eaede35d1e250ad2f9975b16f570d01509f0c5da4597cad
44 lines
1.7 KiB
Makefile
44 lines
1.7 KiB
Makefile
package=zeromq
|
|
$(package)_version=4.3.4
|
|
$(package)_download_path=https://github.com/zeromq/libzmq/releases/download/v$($(package)_version)/
|
|
$(package)_file_name=$(package)-$($(package)_version).tar.gz
|
|
$(package)_sha256_hash=c593001a89f5a85dd2ddf564805deb860e02471171b3f204944857336295c3e5
|
|
$(package)_patches=remove_libstd_link.patch netbsd_kevent_void.patch
|
|
|
|
define $(package)_set_vars
|
|
$(package)_config_opts = --without-docs --disable-shared --disable-valgrind
|
|
$(package)_config_opts += --disable-perf --disable-curve-keygen --disable-curve --disable-libbsd
|
|
$(package)_config_opts += --without-libsodium --without-libgssapi_krb5 --without-pgm --without-norm --without-vmci
|
|
$(package)_config_opts += --disable-libunwind --disable-radix-tree --without-gcov --disable-dependency-tracking
|
|
$(package)_config_opts += --disable-Werror --disable-drafts --enable-option-checking
|
|
$(package)_config_opts_linux=--with-pic
|
|
$(package)_config_opts_freebsd=--with-pic
|
|
$(package)_config_opts_netbsd=--with-pic
|
|
$(package)_config_opts_openbsd=--with-pic
|
|
$(package)_config_opts_android=--with-pic
|
|
$(package)_cxxflags=-std=c++17
|
|
endef
|
|
|
|
define $(package)_preprocess_cmds
|
|
patch -p1 < $($(package)_patch_dir)/remove_libstd_link.patch && \
|
|
patch -p1 < $($(package)_patch_dir)/netbsd_kevent_void.patch && \
|
|
cp -f $(BASEDIR)/config.guess $(BASEDIR)/config.sub config
|
|
endef
|
|
|
|
define $(package)_config_cmds
|
|
./autogen.sh && \
|
|
$($(package)_autoconf)
|
|
endef
|
|
|
|
define $(package)_build_cmds
|
|
$(MAKE) src/libzmq.la
|
|
endef
|
|
|
|
define $(package)_stage_cmds
|
|
$(MAKE) DESTDIR=$($(package)_staging_dir) install-libLTLIBRARIES install-includeHEADERS install-pkgconfigDATA
|
|
endef
|
|
|
|
define $(package)_postprocess_cmds
|
|
rm -rf bin share lib/*.la
|
|
endef
|